{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.nifi:nifi-web-api and nifi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44914 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi-web-api to 2.9.0 or later.","what":"CVE-2026-44914 is a high-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44914 and fix it if it is affected.\n\nWhat it is: CVE-2026-44914 is a high-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi-web-api (Maven): affected from 1.12.0; fixed in 2.9.0\n- org.apache.nifi:nifi-web-api (Maven): affected from 1.12.0; fixed in 2.9.0\n- nifi (Bitnami): affected from 1.12.0; fixed in 2.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44914/ (Markdown: https://insights.sbomify.com/CVE-2026-44914/index.md)","id":"CVE-2026-44914","markdown":"https://insights.sbomify.com/CVE-2026-44914/index.md","name":"CVE-2026-44914","record":{"aliases":["BIT-nifi-2026-44914","CLEANSTART-2026-BA63777","CLEANSTART-2026-JZ19547","GHSA-r2g5-993q-664g","MINI-cj5c-fvj2-m3c9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache NiFi","requires_auth":"high_privilege","summary":"Attackers with write access can bypass restricted permission checks to add privileged components in Apache NiFi, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/S:P/AU:Y/R:U/V:C/RE:L/U:Clear","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Missing Authorization of Restricted Permissions when Replacing Flow Contents","id":"CVE-2026-44914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:nifi","products":["apache:nifi"],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Apache APISIX: Cas-auth plugin open redirect via unsanitized cookie value","id":"CVE-2026-44915"},"packages":[{"ecosystem":"Bitnami","fixed":["2.10.0"],"introduced":["1.12.0"],"last_affected":[],"package":"nifi","purl":"pkg:bitnami/nifi","source":"BIT-nifi-2026-44914"},{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["1.12.0"],"last_affected":[],"package":"org.apache.nifi:nifi-web-api","purl":null,"source":"GHSA-r2g5-993q-664g"},{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["1.12.0"],"last_affected":[],"package":"org.apache.nifi:nifi-web-api","purl":"pkg:maven/org.apache.nifi/nifi-web-api","source":"GHSA-r2g5-993q-664g"}],"prev":{"headline":"Apache NiFi: Improper Escaping of Table Names in CaptureChangeMySQL","id":"CVE-2026-44913"},"products":["Apache NiFi"],"published":"2026-06-22","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-24","vendors":["Apache Software Foundation"]},"summary":"Attackers with write access can bypass restricted permission checks to add privileged components in Apache NiFi, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2026-44914/"}