# CVE-2026-44914: Apache NiFi: Missing Authorization of Restricted Permissions when Replacing Flow Contents

> Attackers with write access can bypass restricted permission checks to add privileged components in Apache NiFi, requiring an upgrade to mitigate.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/S:P/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** BIT-nifi-2026-44914, CLEANSTART-2026-BA63777, CLEANSTART-2026-JZ19547, GHSA-r2g5-993q-664g, MINI-cj5c-fvj2-m3c9

## What is CVE-2026-44914?

CVE-2026-44914 is a high-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44914?

3 open source packages ship an affected version, including org.apache.nifi:nifi-web-api and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.12.0 | 2.9.0 |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.12.0 | 2.9.0 |
| `nifi` | Bitnami | From 1.12.0 | 2.10.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-44914?

Upgrade org.apache.nifi:nifi-web-api to 2.9.0 or later.

## Is CVE-2026-44914 being exploited?

There is no known exploitation of CVE-2026-44914 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44914 and fix it if it is affected.

What it is: CVE-2026-44914 is a high-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44914 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-web-api (Maven): affected from 1.12.0; fixed in 2.9.0
- org.apache.nifi:nifi-web-api (Maven): affected from 1.12.0; fixed in 2.9.0
- nifi (Bitnami): affected from 1.12.0; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44914/ (Markdown: https://insights.sbomify.com/CVE-2026-44914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44914
- OSV: https://osv.dev/vulnerability/CVE-2026-44914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44914/
Summaries are generated and may contain mistakes; the official description above is the record.
