# CVE-2026-44936: Rancher Fleet SSRF in Bundle Reader via Unvalidated Helm Repository URL in fleet.yaml

> Attackers with Git push access can leak Helm credentials by specifying arbitrary URLs in fleet.yaml due to missing validation in Rancher Fleet.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-hx4v-cxpf-vh8m, GO-2026-5873

## What is CVE-2026-44936?

CVE-2026-44936 is a medium-severity server-side request forgery vulnerability in SUSE Rancher, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing filtering when the helmRepoURLRegex field isn't set on a GitRepo resource in SUSE Rancher Fleet's bundle reader in 0.15 before 0.15.2, 0.14 before 0.14.6, 0.13 before 0.13.11 and 0.12 before 0.12.15 forwards Helm authentication credentials (BasicAuth) to any URL specified in the helm.repo field of a fleet.yaml file, allowing attackers able to push to fleet monitored git repos to leak helm access credentials.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44936?

9 open source packages ship an affected version, including github.com/rancher/fleet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15, 0.13.11, 0.14.6, 0.15.2 |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15 |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15 |
| `github.com/rancher/fleet` | Go | From 0.13.0 | 0.13.11 |
| `github.com/rancher/fleet` | Go | From 0.13.0 | 0.13.11 |
| `github.com/rancher/fleet` | Go | From 0.14.0 | 0.14.6 |
| `github.com/rancher/fleet` | Go | From 0.14.0 | 0.14.6 |
| `github.com/rancher/fleet` | Go | From 0.15.0 | 0.15.2 |
| `github.com/rancher/fleet` | Go | From 0.15.0 | 0.15.2 |

Products: Suse Rancher Fleet.

## How do I fix CVE-2026-44936?

Upgrade github.com/rancher/fleet to a fixed version for your release line: 0.12.15, 0.13.11, 0.14.6 or 0.15.2.

## Is CVE-2026-44936 being exploited?

There is no known exploitation of CVE-2026-44936 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2026-44935](https://insights.sbomify.com/CVE-2026-44935/): Rancher Fleet vulnerable to cross namespace secret disclosure via unvalidated `valuesFrom` references in Helm Deployer (critical 9.9)
- [CVE-2026-41050](https://insights.sbomify.com/CVE-2026-41050/): Helm impersonation bypass of `RESTClientGetter` retains `cluster-admin` during template rendering (critical 9.9)
- [CVE-2026-88808](https://insights.sbomify.com/CVE-2026-88808/): Privilege escalation in Rancher (high 8.8)
- [CVE-2026-44938](https://insights.sbomify.com/CVE-2026-44938/): Fleet has PSS Bypass through addLabelsFromOptions in Fleet Agent (high 8.8)
- [CVE-2026-44937](https://insights.sbomify.com/CVE-2026-44937/): SUSE Rancher Fleet had an Unauthenticated Webhook: Regex Injection via Unsanitized Repository URL Components (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44936 and fix it if it is affected.

What it is: CVE-2026-44936 is a medium-severity server-side request forgery vulnerability in SUSE Rancher, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44936 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15, 0.13.11, 0.14.6, 0.15.2
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15
- github.com/rancher/fleet (Go): affected from 0.13.0; fixed in 0.13.11
- github.com/rancher/fleet (Go): affected from 0.13.0; fixed in 0.13.11
- github.com/rancher/fleet (Go): affected from 0.14.0; fixed in 0.14.6
- github.com/rancher/fleet (Go): affected from 0.14.0; fixed in 0.14.6
- github.com/rancher/fleet (Go): affected from 0.15.0; fixed in 0.15.2
- github.com/rancher/fleet (Go): affected from 0.15.0; fixed in 0.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44936/ (Markdown: https://insights.sbomify.com/CVE-2026-44936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44936
- OSV: https://osv.dev/vulnerability/CVE-2026-44936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44936/
Summaries are generated and may contain mistakes; the official description above is the record.
