# CVE-2026-44937: SUSE Rancher Fleet had an Unauthenticated Webhook: Regex Injection via Unsanitized Repository URL Components

> Remote attackers can forge webhook requests via unsanitized URLs in unauthenticated webhooks, causing denial of service or downgrade attacks.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-jmf4-m7j9-g72r, GO-2026-5874

## What is CVE-2026-44937?

CVE-2026-44937 is a high-severity server-side request forgery vulnerability in SUSE Rancher, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Potential forgery of webhook requests when using a unauthenticated webhook in SUSE Rancher Fleet 0.15 before 0.15.2, 0.14 before 0.14.6, 0.13 before 0.13.11 and 0.12 before 0.12.5 could be used by remote attackers to cause a denial of service or a downgrade attack on other repositories on the system.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44937?

9 open source packages ship an affected version, including github.com/rancher/fleet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15, 0.13.11, 0.14.6, 0.15.2 |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15 |
| `github.com/rancher/fleet` | Go | From 0.12.0 | 0.12.15 |
| `github.com/rancher/fleet` | Go | From 0.13.0 | 0.13.11 |
| `github.com/rancher/fleet` | Go | From 0.13.0 | 0.13.11 |
| `github.com/rancher/fleet` | Go | From 0.14.0 | 0.14.6 |
| `github.com/rancher/fleet` | Go | From 0.14.0 | 0.14.6 |
| `github.com/rancher/fleet` | Go | From 0.15.0 | 0.15.2 |
| `github.com/rancher/fleet` | Go | From 0.15.0 | 0.15.2 |

Products: Suse Rancher Fleet.

## How do I fix CVE-2026-44937?

Upgrade github.com/rancher/fleet to a fixed version for your release line: 0.12.15, 0.13.11, 0.14.6 or 0.15.2.

## Is CVE-2026-44937 being exploited?

There is no known exploitation of CVE-2026-44937 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2026-44935](https://insights.sbomify.com/CVE-2026-44935/): Rancher Fleet vulnerable to cross namespace secret disclosure via unvalidated `valuesFrom` references in Helm Deployer (critical 9.9)
- [CVE-2026-41050](https://insights.sbomify.com/CVE-2026-41050/): Helm impersonation bypass of `RESTClientGetter` retains `cluster-admin` during template rendering (critical 9.9)
- [CVE-2026-88808](https://insights.sbomify.com/CVE-2026-88808/): Privilege escalation in Rancher (high 8.8)
- [CVE-2026-44938](https://insights.sbomify.com/CVE-2026-44938/): Fleet has PSS Bypass through addLabelsFromOptions in Fleet Agent (high 8.8)
- [CVE-2026-93538](https://insights.sbomify.com/CVE-2026-93538/): Missing authorization in Rancher (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44937 and fix it if it is affected.

What it is: CVE-2026-44937 is a high-severity server-side request forgery vulnerability in SUSE Rancher, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44937 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15, 0.13.11, 0.14.6, 0.15.2
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15
- github.com/rancher/fleet (Go): affected from 0.12.0; fixed in 0.12.15
- github.com/rancher/fleet (Go): affected from 0.13.0; fixed in 0.13.11
- github.com/rancher/fleet (Go): affected from 0.13.0; fixed in 0.13.11
- github.com/rancher/fleet (Go): affected from 0.14.0; fixed in 0.14.6
- github.com/rancher/fleet (Go): affected from 0.14.0; fixed in 0.14.6
- github.com/rancher/fleet (Go): affected from 0.15.0; fixed in 0.15.2
- github.com/rancher/fleet (Go): affected from 0.15.0; fixed in 0.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44937/ (Markdown: https://insights.sbomify.com/CVE-2026-44937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44937
- OSV: https://osv.dev/vulnerability/CVE-2026-44937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44937/
Summaries are generated and may contain mistakes; the official description above is the record.
