# CVE-2026-44939: Command injection through unsanitized YAML parameter in Rancher

> Remote attackers can execute malicious containers via command injection in the Rancher cluster import endpoint.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-mhc6-2gfq-xx62, GO-2026-5875

## What is CVE-2026-44939?

CVE-2026-44939 is a critical command injection vulnerability in SUSE Rancher, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A command injection vulnerability in the Rancher Manager cluster before 2.14.2 import endpoint  /v3/import/{token}_{clusterId}.yaml through unsanitized YAML parameters could allow remote attackers to break out of an image, and execute e.g. malicious containers.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-44939?

13 open source packages ship an affected version, including github.com/rancher/rancher.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260617231817-2aa77eb283e7 |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260617231817-2aa77eb283e7 |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260617231817-2aa77eb283e7 |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.12 |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.12 |
| `github.com/rancher/rancher` | Go | From 2.11.0 | 2.11.14 |
| `github.com/rancher/rancher` | Go | From 2.11.0 | 2.11.14 |
| `github.com/rancher/rancher` | Go | From 2.12.0 | 2.12.10 |
| `github.com/rancher/rancher` | Go | From 2.12.0 | 2.12.10 |
| `github.com/rancher/rancher` | Go | From 2.13.0 | 2.13.6 |
| `github.com/rancher/rancher` | Go | From 2.13.0 | 2.13.6 |
| `github.com/rancher/rancher` | Go | From 2.14.0 | 2.14.2 |
| `github.com/rancher/rancher` | Go | From 2.14.0 | 2.14.2 |

## How do I fix CVE-2026-44939?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 0.0.0-20260617231817-2aa77eb283e7, 2.10.12, 2.11.14 or 2.12.10.

## Is CVE-2026-44939 being exploited?

There is no known exploitation of CVE-2026-44939 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44939 and fix it if it is affected.

What it is: CVE-2026-44939 is a critical command injection vulnerability in SUSE Rancher, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44939 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260617231817-2aa77eb283e7
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260617231817-2aa77eb283e7
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260617231817-2aa77eb283e7
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.12
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.12
- github.com/rancher/rancher (Go): affected from 2.11.0; fixed in 2.11.14
- github.com/rancher/rancher (Go): affected from 2.11.0; fixed in 2.11.14
- github.com/rancher/rancher (Go): affected from 2.12.0; fixed in 2.12.10
- github.com/rancher/rancher (Go): affected from 2.12.0; fixed in 2.12.10
- github.com/rancher/rancher (Go): affected from 2.13.0; fixed in 2.13.6
- github.com/rancher/rancher (Go): affected from 2.13.0; fixed in 2.13.6
- github.com/rancher/rancher (Go): affected from 2.14.0; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44939/ (Markdown: https://insights.sbomify.com/CVE-2026-44939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44939
- OSV: https://osv.dev/vulnerability/CVE-2026-44939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44939/
Summaries are generated and may contain mistakes; the official description above is the record.
