{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44941 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-44941 is a high-severity path traversal vulnerability in SUSE libzypp, published on 2 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44941 and fix it if it is affected.\n\nWhat it is: CVE-2026-44941 is a high-severity path traversal vulnerability in SUSE libzypp, published on 2 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44941 in the wild and no public exploit code.\n\nAffected product: SUSE libzypp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44941/ (Markdown: https://insights.sbomify.com/CVE-2026-44941/index.md)","id":"CVE-2026-44941","markdown":"https://insights.sbomify.com/CVE-2026-44941/index.md","name":"CVE-2026-44941","record":{"aliases":["DEBIAN-CVE-2026-44941","GHSA-wp9x-wjhc-28mv","SUSE-SU-2026:22062-1","UBUNTU-CVE-2026-44941"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"libzypp package manager","requires_auth":"high_privilege","summary":"Attackers can inject or overwrite files as root via malicious repository metadata, requiring an upgrade to libzypp.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"libzypp","vendor":"opensuse"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"A relative path traversal in the \"keyhint\" option in repomd.xml parsing of libzypp before 17.38.12 can be used by attackers able to supply a malicious repository to inject or overwrite files in the target system as root.","ecosystems":["SUSE:Linux Micro 6.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libzypp path traversal via \"keyhint\" in repomd.xml","id":"CVE-2026-44941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"libzypp .repo files can have an optional path which can lead to path traversal attacks","id":"CVE-2026-44942"},"packages":[{"ecosystem":"SUSE:Linux Micro 6.0","fixed":["17.38.12-1.1"],"introduced":["0"],"last_affected":[],"package":"libzypp","purl":"pkg:rpm/suse/libzypp\u0026distro=SUSE%20Linux%20Micro%206.0","source":"SUSE-SU-2026:22062-1"}],"prev":{"headline":"Service token exposure and potential privilege escalation in SUSE Observability","id":"CVE-2026-44940"},"products":["libzypp"],"published":"2026-07-02","related":[{"cvss_score":8.8,"headline":"Handcrafted repo metadata may cause arbitrary local files to be overwritten by libzypp","id":"CVE-2026-25707","kev_date_added":null,"published":"2026-06-29"},{"cvss_score":8.1,"headline":"libzypp accepts unsigned 3rd party repo without warning","id":"CVE-2017-7435","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":8.1,"headline":"libzypp accepts unsigned packages even when configured to check signatures","id":"CVE-2017-7436","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":7.8,"headline":"libzypp does not reevaluate malicious rpms once downloaded","id":"CVE-2018-7685","kev_date_added":null,"published":"2018-08-31"},{"cvss_score":7.7,"headline":"lack of keypinning in libzypp could lead to repository switching","id":"CVE-2017-9269","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":4,"headline":"libzypp stores cookies world readable","id":"CVE-2019-18900","kev_date_added":null,"published":"2020-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-07","vendors":["SUSE"]},"summary":"Attackers can inject or overwrite files as root via malicious repository metadata, requiring an upgrade to libzypp.","url":"https://insights.sbomify.com/CVE-2026-44941/"}