# CVE-2026-44977: countly-server: Stored XSS in feedback upload enables app-admin to compromise global admin session context

> A stored XSS vulnerability in Countly server allows app-admins to compromise global admin sessions by uploading malicious feedback files.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-jqp4-p86c-phxc

## What is CVE-2026-44977?

CVE-2026-44977 is a critical cross-site scripting vulnerability in countly-server, published on 16 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

countly-server is the server-side part of Countly, a product analytics solution. Prior to 24.05.50 and 25.03.44, plugins/star-rating/api/api.js allows a non-global application administrator to use uploadFeedbackFile to store attacker-controlled active content while trusting the supplied MIME type. plugins/star-rating/frontend/app.js publicly serves the stored content from feedback/preview/ with the attacker-influenced Content-Type, so a global administrator who opens the preview executes the payload in the Countly origin and exposes authenticated session capabilities, including auth_token and csrf_token values. This issue is fixed in versions 24.05.50 and 25.03.44.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44977?


## How do I fix CVE-2026-44977?

No fix has been published for CVE-2026-44977 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44977 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44977 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44977 and fix it if it is affected.

What it is: CVE-2026-44977 is a critical cross-site scripting vulnerability in countly-server, published on 16 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44977 exists.

Affected product: countly-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44977/ (Markdown: https://insights.sbomify.com/CVE-2026-44977/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44977
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44977
- OSV: https://osv.dev/vulnerability/CVE-2026-44977

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44977/
Summaries are generated and may contain mistakes; the official description above is the record.
