{"answers":{"affected":"2 open source packages ship an affected version, including @hapi/wreck.","exploited":"There is no known exploitation of CVE-2026-44979 in the wild and no public exploit code.","fix":"Upgrade @hapi/wreck to 18.1.1 or later.","what":"CVE-2026-44979 is a medium-severity vulnerability in hapijs wreck, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44979 and fix it if it is affected.\n\nWhat it is: CVE-2026-44979 is a medium-severity vulnerability in hapijs wreck, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44979 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hapi/wreck (npm): affected all versions; fixed in 18.1.1\n- @hapi/wreck (npm): affected all versions; fixed in 18.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44979/ (Markdown: https://insights.sbomify.com/CVE-2026-44979/index.md)","id":"CVE-2026-44979","markdown":"https://insights.sbomify.com/CVE-2026-44979/index.md","name":"CVE-2026-44979","record":{"aliases":["CLEANSTART-2026-RN50585","GHSA-vhjm-w67q-g75c","MINI-2hf6-735q-x2vh","MINI-2j25-9grm-g845","MINI-3627-mqwj-f8wm","MINI-5g7p-cj84-5pw7","MINI-6465-gmv3-chr6","MINI-677j-53q5-h352","MINI-8cf7-9rrw-qf7x","MINI-f856-49qw-vv3r","MINI-gg7w-7x93-j72j","MINI-j44g-gpxc-g42v","MINI-p8mj-wp34-6px4","MINI-v35q-qxxg-6xw4","MINI-vp9m-vj26-459w","MINI-vv84-q7hx-772g","MINI-xh7g-6qxf-6cr7","ROOT-APP-NPM-CVE-2026-44979"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"Attackers can steal Proxy-Authorization credentials when the library follows cross-host redirects, exposing sensitive proxy authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"@hapi/wreck is an HTTP client utility. Prior to 18.1.1, when @hapi/wreck follows a 3xx redirect to a different hostname, only the Authorization and Cookie headers are stripped, and the standard credential header Proxy-Authorization is forwarded intact to the redirect target, potentially exposing forward-proxy credentials to a host outside the original trust boundary when redirects are enabled through the redirects option or Wreck.defaults({ redirects: ... }). This issue is fixed in version 18.1.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@hapi/wreck : Sensitive `Proxy-Authorization` header leaked across cross-hostname redirects","id":"CVE-2026-44979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression","id":"CVE-2026-44981"},"packages":[{"ecosystem":"npm","fixed":["18.1.1"],"introduced":["0"],"last_affected":[],"package":"@hapi/wreck","purl":null,"source":"GHSA-vhjm-w67q-g75c"},{"ecosystem":"npm","fixed":["18.1.1"],"introduced":["0"],"last_affected":[],"package":"@hapi/wreck","purl":"pkg:npm/%40hapi/wreck","source":"GHSA-vhjm-w67q-g75c"}],"prev":{"headline":"xrdp: Unchecked FIPS padding length in standard RDP Security causes heap out-of-bounds read in HMAC verification","id":"CVE-2026-44978"},"products":["wreck"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["hapijs"]},"summary":"Attackers can steal Proxy-Authorization credentials when the library follows cross-host redirects, exposing sensitive proxy authentication data.","url":"https://insights.sbomify.com/CVE-2026-44979/"}