{"answers":{"affected":"3 open source packages ship an affected version, including github.com/crowdsecurity/crowdsec.","exploited":"There is no known exploitation of CVE-2026-44981 in the wild and no public exploit code.","fix":"Upgrade github.com/crowdsecurity/crowdsec to 1.7.8 or later.","what":"CVE-2026-44981 is a high-severity denial of service vulnerability in crowdsecurity crowdsec, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44981 and fix it if it is affected.\n\nWhat it is: CVE-2026-44981 is a high-severity denial of service vulnerability in crowdsecurity crowdsec, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44981 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/crowdsecurity/crowdsec (Go): affected from 1.7.0; fixed in 1.7.8\n- github.com/crowdsecurity/crowdsec (Go): affected from 1.7.0; fixed in 1.7.8\n- github.com/crowdsecurity/crowdsec (Go): affected from 1.7.0; fixed in 1.7.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44981/ (Markdown: https://insights.sbomify.com/CVE-2026-44981/index.md)","id":"CVE-2026-44981","markdown":"https://insights.sbomify.com/CVE-2026-44981/index.md","name":"CVE-2026-44981","record":{"aliases":["GHSA-273h-gvwr-c3qj","GO-2026-5041","UBUNTU-CVE-2026-44981"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CrowdSec LAPI","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service in CrowdSec LAPI by sending large gzip-compressed requests, leading to excessive memory consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression","id":"CVE-2026-44981","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"CrowdSec AppSec silently drops request body for chunked / HTTP-2 requests","id":"CVE-2026-44982"},"packages":[{"ecosystem":"Go","fixed":["1.7.8"],"introduced":["1.7.0"],"last_affected":[],"package":"github.com/crowdsecurity/crowdsec","purl":null,"source":"GHSA-273h-gvwr-c3qj"},{"ecosystem":"Go","fixed":["1.7.8"],"introduced":["1.7.0"],"last_affected":[],"package":"github.com/crowdsecurity/crowdsec","purl":"pkg:golang/github.com/crowdsecurity/crowdsec","source":"GHSA-273h-gvwr-c3qj"},{"ecosystem":"Go","fixed":["1.7.8"],"introduced":["1.7.0"],"last_affected":[],"package":"github.com/crowdsecurity/crowdsec","purl":"pkg:golang/github.com/crowdsecurity/crowdsec","source":"GO-2026-5041"}],"prev":{"headline":"@hapi/wreck : Sensitive `Proxy-Authorization` header leaked across cross-hostname redirects","id":"CVE-2026-44979"},"products":["crowdsec"],"published":"2026-07-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-17","vendors":["crowdsecurity"]},"summary":"Unauthenticated attackers can cause denial of service in CrowdSec LAPI by sending large gzip-compressed requests, leading to excessive memory consumption.","url":"https://insights.sbomify.com/CVE-2026-44981/"}