# CVE-2026-44982: CrowdSec AppSec silently drops request body for chunked / HTTP-2 requests

> Attackers can bypass WAF rules by sending chunked or HTTP/2 requests, causing CrowdSec to ignore request bodies.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-rw47-hm26-6wr7, GO-2026-5641, UBUNTU-CVE-2026-44982

## What is CVE-2026-44982?

CVE-2026-44982 is a high-severity vulnerability in crowdsecurity crowdsec, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CrowdSec offers crowdsourced protection against malicious IPs. From 1.5.0 until 1.7.8, pkg/appsec/request.go NewParsedRequestFromRequest allocated a request body buffer from max(r.ContentLength, 0), so HTTP/1.1 requests using Transfer-Encoding: chunked and HTTP/2 requests without a content-length header produced an empty body and caused WAF rules targeting REQUEST_BODY, BODY_ARGS, ARGS_POST, JSON, or XML to be skipped. This issue is fixed in version 1.7.8.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-44982?

3 open source packages ship an affected version, including github.com/crowdsecurity/crowdsec.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/crowdsecurity/crowdsec` | Go | From 1.5.0 | 1.7.8 |
| `github.com/crowdsecurity/crowdsec` | Go | From 1.5.0 | 1.7.8 |
| `github.com/crowdsecurity/crowdsec` | Go | From 1.5.0 | 1.7.8 |

## How do I fix CVE-2026-44982?

Upgrade github.com/crowdsecurity/crowdsec to 1.7.8 or later.

## Is CVE-2026-44982 being exploited?

There is no known exploitation of CVE-2026-44982 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44982 and fix it if it is affected.

What it is: CVE-2026-44982 is a high-severity vulnerability in crowdsecurity crowdsec, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44982 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/crowdsecurity/crowdsec (Go): affected from 1.5.0; fixed in 1.7.8
- github.com/crowdsecurity/crowdsec (Go): affected from 1.5.0; fixed in 1.7.8
- github.com/crowdsecurity/crowdsec (Go): affected from 1.5.0; fixed in 1.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44982/ (Markdown: https://insights.sbomify.com/CVE-2026-44982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44982
- OSV: https://osv.dev/vulnerability/CVE-2026-44982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44982/
Summaries are generated and may contain mistakes; the official description above is the record.
