# CVE-2026-44987: SysReptor: Privilege Escalation from User Admin to Superuser

> User admins can escalate to superuser by resetting passwords if password recovery is enabled and MFA is absent, granting full administrative access.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-6x8f-v3cf-cvr3

## What is CVE-2026-44987?

CVE-2026-44987 is a low-severity vulnerability in Syslifters sysreptor, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

SysReptor is a fully customizable pentest reporting platform. Prior to version 2026.29, users with "User Admin" permissions can change the email addresses of users with "Superuser" permissions. If the SysReptor installation has the "Forgot Password" functionality enabled (non-default), they can reset the Superusers' passwords and authenticate, if the Superuser has no MFA enabled. User managers can then access the Django backend (/admin) or manipulate the settings of the SysReptor installation. Note that user managers have the ability to access all pentest projects by assigning themselves "Project Admin" permissions. This is intentional and by design. This issue has been patched in version 2026.29.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-44987?


## How do I fix CVE-2026-44987?

No fix has been published for CVE-2026-44987 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44987 being exploited?

There is no known exploitation of CVE-2026-44987 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44987 and fix it if it is affected.

What it is: CVE-2026-44987 is a low-severity vulnerability in Syslifters sysreptor, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44987 in the wild and no public exploit code.

Affected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44987/ (Markdown: https://insights.sbomify.com/CVE-2026-44987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44987
- OSV: https://osv.dev/vulnerability/CVE-2026-44987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44987/
Summaries are generated and may contain mistakes; the official description above is the record.
