{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-44988 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-44988 is a high-severity memory corruption vulnerability in libvncserver, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44988 and fix it if it is affected.\n\nWhat it is: CVE-2026-44988 is a high-severity memory corruption vulnerability in libvncserver, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44988 in the wild and no public exploit code.\n\nAffected product: libvncserver. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44988/ (Markdown: https://insights.sbomify.com/CVE-2026-44988/index.md)","id":"CVE-2026-44988","markdown":"https://insights.sbomify.com/CVE-2026-44988/index.md","name":"CVE-2026-44988","record":{"aliases":["DEBIAN-CVE-2026-44988","GHSA-jcc5-8wj4-7c58","OESA-2026-2490","OESA-2026-2491","OESA-2026-2564","OESA-2026-2565","SUSE-SU-2026:22190-1","SUSE-SU-2026:2227-1","SUSE-SU-2026:2427-1","SUSE-SU-2026:2428-1","UBUNTU-CVE-2026-44988","openSUSE-SU-2026:10905-1","openSUSE-SU-2026:21118-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"VNC client library","requires_auth":"none","summary":"A malicious VNC server can trigger out-of-bounds writes in LibVNCClient via crafted Tight encoding rectangles, potentially leading to code execution on the client.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"LibVNCClient is a library for easy implementation of a VNC client. In 0.9.15 and earlier, LibVNCClient's Tight encoding decoder uses fixed-size 2048-pixel scratch buffers for the Gradient filter, but it does not reject Tight rectangles whose width is larger than 2048 pixels. A malicious VNC server can send a crafted FramebufferUpdate rectangle using Tight encoding with NoZlib | ExplicitFilter and the Gradient filter. When a LibVNCClient-based client connects, the client processes the server-controlled rectangle width and writes beyond fixed-size Gradient buffers. This vulnerability is fixed with commit 5b270544b85233668b98161323297d418a8f5fd1.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Linux Enterprise Server 12 SP5-LTSS","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Enterprise Workstation Extension 15 SP7","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LibVNCClient Tight Gradient decoding allows malicious server-triggered heap/stack OOB writes","id":"CVE-2026-44988","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":8,"n_references":2,"next":{"headline":"Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html`","id":"CVE-2026-44990"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["0.9.14-150600.3.9.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2026:2427-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["0.9.9-17.47.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2026:2428-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["0.9.14-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22190-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["0.9.9-17.47.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:2428-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["0.9.14-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22190-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 15 SP7","fixed":["0.9.14-150600.3.9.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/suse/LibVNCServer\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2015%20SP7","source":"SUSE-SU-2026:2427-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["0.9.14-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/opensuse/LibVNCServer\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21118-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9.15-3.1"],"introduced":["0"],"last_affected":[],"package":"LibVNCServer","purl":"pkg:rpm/opensuse/LibVNCServer\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10905-1"}],"prev":{"headline":"SysReptor: Privilege Escalation from User Admin to Superuser","id":"CVE-2026-44987"},"products":["libvncserver"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["LibVNC"]},"summary":"A malicious VNC server can trigger out-of-bounds writes in LibVNCClient via crafted Tight encoding rectangles, potentially leading to code execution on the client.","url":"https://insights.sbomify.com/CVE-2026-44988/"}