{"answers":{"affected":"2 open source packages ship an affected version, including sanitize-html.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44990 exists.","fix":"Upgrade sanitize-html to 2.17.4 or later.","what":"CVE-2026-44990 is a critical cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44990 and fix it if it is affected.\n\nWhat it is: CVE-2026-44990 is a critical cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44990 exists.\n\nAffected packages and fixed versions:\n- sanitize-html (npm): affected from 2.17.3; fixed in 2.17.4\n- sanitize-html (npm): affected from 2.17.3; fixed in 2.17.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44990/ (Markdown: https://insights.sbomify.com/CVE-2026-44990/index.md)","id":"CVE-2026-44990","markdown":"https://insights.sbomify.com/CVE-2026-44990/index.md","name":"CVE-2026-44990","record":{"aliases":["GHSA-rpr9-rxv7-x643","MINI-334f-vv72-xhpj","ROOT-APP-NPM-CVE-2026-44990"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTML sanitizer","requires_auth":"none","summary":"Attackers can inject malicious scripts via xmp tags in sanitized content, leading to stored XSS in applications using the vulnerable library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Under the default configuration, versions of `sanitize-html` prior to 2.17.4 can turn attacker-controlled content inside a disallowed `xmp` element into live HTML or JavaScript. This is a sanitizer bypass in the default `disallowedTagsMode: 'discard'` path and can lead to stored XSS in applications that render sanitized output back to users. Version 2.17.4 patches the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html`","id":"CVE-2026-44990","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"OpenClaw \u003c 2026.4.21 - Authorization Bypass in Owner-Enforced Commands via Wildcard Channel Senders","id":"CVE-2026-44991"},"packages":[{"ecosystem":"npm","fixed":["2.17.4"],"introduced":["2.17.3"],"last_affected":[],"package":"sanitize-html","purl":null,"source":"GHSA-rpr9-rxv7-x643"},{"ecosystem":"npm","fixed":["2.17.4"],"introduced":["2.17.3"],"last_affected":[],"package":"sanitize-html","purl":"pkg:npm/sanitize-html","source":"GHSA-rpr9-rxv7-x643"}],"prev":{"headline":"LibVNCClient Tight Gradient decoding allows malicious server-triggered heap/stack OOB writes","id":"CVE-2026-44988"},"products":["sanitize-html"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["apostrophecms"]},"summary":"Attackers can inject malicious scripts via xmp tags in sanitized content, leading to stored XSS in applications using the vulnerable library.","url":"https://insights.sbomify.com/CVE-2026-44990/"}