# CVE-2026-44990: Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html`

> Attackers can inject malicious scripts via xmp tags in sanitized content, leading to stored XSS in applications using the vulnerable library.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-rpr9-rxv7-x643, MINI-334f-vv72-xhpj, ROOT-APP-NPM-CVE-2026-44990

## What is CVE-2026-44990?

CVE-2026-44990 is a critical cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Under the default configuration, versions of `sanitize-html` prior to 2.17.4 can turn attacker-controlled content inside a disallowed `xmp` element into live HTML or JavaScript. This is a sanitizer bypass in the default `disallowedTagsMode: 'discard'` path and can lead to stored XSS in applications that render sanitized output back to users. Version 2.17.4 patches the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44990?

2 open source packages ship an affected version, including sanitize-html.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | From 2.17.3 | 2.17.4 |
| `sanitize-html` | npm | From 2.17.3 | 2.17.4 |

## How do I fix CVE-2026-44990?

Upgrade sanitize-html to 2.17.4 or later.

## Is CVE-2026-44990 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44990 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44990 and fix it if it is affected.

What it is: CVE-2026-44990 is a critical cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44990 exists.

Affected packages and fixed versions:
- sanitize-html (npm): affected from 2.17.3; fixed in 2.17.4
- sanitize-html (npm): affected from 2.17.3; fixed in 2.17.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44990/ (Markdown: https://insights.sbomify.com/CVE-2026-44990/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44990
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44990
- OSV: https://osv.dev/vulnerability/CVE-2026-44990

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44990/
Summaries are generated and may contain mistakes; the official description above is the record.
