CVE-2026-44998 OpenClaw < 2026.4.20 - Tool Policy Bypass via Bundled MCP/LSP Tools
Attackers with local agent access can bypass tool restrictions in OpenClaw by appending restricted MCP/LSP tools to the effective set.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44998?
CVE-2026-44998 is a low-severity vulnerability in Openclaw Openclaw, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.4.20 contains a tool policy bypass vulnerability allowing bundled MCP and LSP tools to circumvent configured tool restrictions. Attackers with local agent access can append restricted tools to the effective tool set after policy filtering, bypassing profile policies, allow/deny lists, owner-only restrictions, sandbox policies, and subagent policies.
Weakness: CWE-863
Which versions are affected by CVE-2026-44998?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.20 |
openclaw npm | All versions | 2026.4.20 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-44998?
Upgrade openclaw to 2026.4.20 or later.
Is CVE-2026-44998 being exploited?
There is no known exploitation of CVE-2026-44998 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-fr55-95rr-vm5x, GHSA-qrp5-gfw2-gxv4, MINI-6xq5-jj6m-cp5v, MINI-hv4c-qj95-cpcp.