CVE-2026-4500 bagofwords1 bagofwords code_execution.py generate_df injection

Medium 5.3 Published Updated

Remote attackers can execute arbitrary code via injection in the generate_df function of the bagofwords web application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-4500?

CVE-2026-4500 is a medium-severity code injection vulnerability in bagofwords1 bagofwords, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was identified in bagofwords1 bagofwords up to 0.0.297. This impacts the function generate_df of the file backend/app/ai/code_execution/code_execution.py. Such manipulation leads to injection. The attack may be launched remotely. The exploit is publicly available and might be used. Upgrading to version 0.0.298 will fix this issue. The name of the patch is 47b20bcda31264635faff7f6b1c8095abe1861c6. It is recommended to upgrade the affected component.

Weakness: CWE-74, CWE-707

Which versions are affected by CVE-2026-4500?

How do I fix CVE-2026-4500?

No fix has been published for CVE-2026-4500 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-4500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4500 exists.

Sources

Also known as GHSA-p4qq-95g8-66mx.

Is CVE-2026-4500 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free