# CVE-2026-4500: bagofwords1 bagofwords code_execution.py generate_df injection

> Remote attackers can execute arbitrary code via injection in the generate_df function of the bagofwords web application.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-p4qq-95g8-66mx

## What is CVE-2026-4500?

CVE-2026-4500 is a medium-severity code injection vulnerability in bagofwords1 bagofwords, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was identified in bagofwords1 bagofwords up to 0.0.297. This impacts the function generate_df of the file backend/app/ai/code_execution/code_execution.py. Such manipulation leads to injection. The attack may be launched remotely. The exploit is publicly available and might be used. Upgrading to version 0.0.298 will fix this issue. The name of the patch is 47b20bcda31264635faff7f6b1c8095abe1861c6. It is recommended to upgrade the affected component.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2026-4500?


## How do I fix CVE-2026-4500?

No fix has been published for CVE-2026-4500 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-4500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4500 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4500 and fix it if it is affected.

What it is: CVE-2026-4500 is a medium-severity code injection vulnerability in bagofwords1 bagofwords, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4500 exists.

Affected product: bagofwords1 bagofwords. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4500/ (Markdown: https://insights.sbomify.com/CVE-2026-4500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4500
- OSV: https://osv.dev/vulnerability/CVE-2026-4500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4500/
Summaries are generated and may contain mistakes; the official description above is the record.
