{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45010 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.2 or later.","what":"CVE-2026-45010 is a critical authentication bypass vulnerability in thorsten phpmyfaq, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45010 and fix it if it is affected.\n\nWhat it is: CVE-2026-45010 is a critical authentication bypass vulnerability in thorsten phpmyfaq, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45010 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45010/ (Markdown: https://insights.sbomify.com/CVE-2026-45010/index.md)","id":"CVE-2026-45010","markdown":"https://insights.sbomify.com/CVE-2026-45010/index.md","name":"CVE-2026-45010","record":{"aliases":["GHSA-9pq7-mfwh-xx2j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"none","summary":"Unauthenticated attackers can brute-force TOTP codes via the admin check endpoint to bypass two-factor authentication and gain administrative access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"phpMyFAQ before 4.1.2 contains an improper restriction of excessive authentication attempts vulnerability in the /admin/check endpoint, which accepts arbitrary user-id parameters without session binding or rate limiting. Unauthenticated attackers can brute-force any user's six-digit TOTP code by submitting POST requests with sequential token values, bypassing two-factor authentication to gain full administrative access.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint","id":"CVE-2026-45010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Apostrophe has stored XSS via javascript: URL in Image Widget Link","id":"CVE-2026-45011"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-9pq7-mfwh-xx2j"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-9pq7-mfwh-xx2j"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-9pq7-mfwh-xx2j"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-9pq7-mfwh-xx2j"}],"prev":{"headline":"phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints","id":"CVE-2026-45009"},"products":["phpmyfaq"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["thorsten"]},"summary":"Unauthenticated attackers can brute-force TOTP codes via the admin check endpoint to bypass two-factor authentication and gain administrative access.","url":"https://insights.sbomify.com/CVE-2026-45010/"}