# CVE-2026-45017: Python Liquid: Absolute paths escape filesystem loader search path

> Malicious template authors can read arbitrary files outside the search path using absolute paths in include or render tags.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** ECHO-4c7e-d60c-e7b1, GHSA-8p4x-wr7x-3788, PYSEC-2026-192

## What is CVE-2026-45017?

CVE-2026-45017 is a high-severity path traversal vulnerability in jg-rp liquid, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python Liquid is a Python engine for the Liquid template language. Prior to 2.2.0, the built-in FileSystemLoader and CachingFileSystemLoader do not guard against reading files outside their search paths when given an absolute path to resolve. This allows malicious template authors to load and render arbitrary files via the {% include %} and {% render %} tags. Targeted files would need to contain valid Liquid markup and be readable by the application process. This vulnerability is fixed in 2.2.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-45017?

3 open source packages ship an affected version, including python-liquid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-liquid` | PyPI | All versions | 2.2.0 |
| `python-liquid` | PyPI | All versions | 2.2.0 |
| `python-liquid` | PyPI | All versions | 2.2.0 |

Products: Jg-Rp Python Liquid.

## How do I fix CVE-2026-45017?

Upgrade python-liquid to 2.2.0 or later.

## Is CVE-2026-45017 being exploited?

There is no known exploitation of CVE-2026-45017 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45017 and fix it if it is affected.

What it is: CVE-2026-45017 is a high-severity path traversal vulnerability in jg-rp liquid, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45017 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-liquid (PyPI): affected all versions; fixed in 2.2.0
- python-liquid (PyPI): affected all versions; fixed in 2.2.0
- python-liquid (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45017/ (Markdown: https://insights.sbomify.com/CVE-2026-45017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45017
- OSV: https://osv.dev/vulnerability/CVE-2026-45017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45017/
Summaries are generated and may contain mistakes; the official description above is the record.
