# CVE-2026-45018: Chainlit: Command injection via MCP stdio transport allows unauthenticated remote code execution

> Unauthenticated attackers can execute arbitrary shell commands via the MCP stdio endpoint if MCP features are enabled, leading to remote code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-w3fx-mc44-mf6j, PYSEC-2026-3812

## What is CVE-2026-45018?

CVE-2026-45018 is a critical command injection vulnerability in chainlit, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Chainlit is a Python framework for building production-ready conversational AI applications. From 2.4.0rc0 until 2.12.0, Chainlit deployments with features.mcp.enabled set to true in .chainlit/config.toml expose the POST /mcp endpoint without requiring authentication. For stdio transport, the endpoint accepts a user-controlled fullCommand string. The validate_mcp_command() function in backend/chainlit/mcp.py checks only the executable name against config.features.mcp.stdio.allowed_executables and passes unchecked arguments to StdioServerParameters in backend/chainlit/server.py. Because npx supports the -c argument, an attacker can execute arbitrary shell commands with the privileges of the Chainlit process. If allowed_executables is unset, its None default is treated as allowing every executable. This issue is fixed in version 2.12.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-45018?

3 open source packages ship an affected version, including chainlit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainlit` | PyPI | From 2.4.0rc0 | 2.12.0 |
| `chainlit` | PyPI | From 2.4.0rc0 | 2.12.0 |
| `chainlit` | PyPI | From 2.4.0rc0 | 2.12.0 |

## How do I fix CVE-2026-45018?

Upgrade chainlit to 2.12.0 or later.

## Is CVE-2026-45018 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45018 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45018 and fix it if it is affected.

What it is: CVE-2026-45018 is a critical command injection vulnerability in chainlit, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45018 exists.

Affected packages and fixed versions:
- chainlit (PyPI): affected from 2.4.0rc0; fixed in 2.12.0
- chainlit (PyPI): affected from 2.4.0rc0; fixed in 2.12.0
- chainlit (PyPI): affected from 2.4.0rc0; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45018/ (Markdown: https://insights.sbomify.com/CVE-2026-45018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45018
- OSV: https://osv.dev/vulnerability/CVE-2026-45018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45018/
Summaries are generated and may contain mistakes; the official description above is the record.
