# CVE-2026-45021: Kuma: Default kuma-cp leaks admin token cross-origin via CORS wildcard + LocalhostIsAdmin

> Default Kuma control plane configuration leaks admin tokens and signing keys to malicious websites via permissive CORS and localhost admin privileges.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** ECHO-92ea-6473-9f56

## What is CVE-2026-45021?

CVE-2026-45021 is a medium-severity vulnerability in kumahq kuma, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.25, 2.9.15, 2.11.13, 2.12.10, and 2.13.5, the default kuma-cp config leaks the admin bootstrap token and signing keys to any webpage the operator visits while the control plane is reachable from their browser. CorsAllowedDomains: [".*"] reflects any Origin, and LocalhostIsAdmin: true promotes requests from 127.0.0.1 to mesh-system:admin. A cross-origin fetch() from a malicious page returns the admin JWT and signing material. This vulnerability is fixed in 2.7.25, 2.9.15, 2.11.13, 2.12.10, and 2.13.5.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-45021?


## How do I fix CVE-2026-45021?

Upgrade to a fixed version.

## Is CVE-2026-45021 being exploited?

There is no known exploitation of CVE-2026-45021 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45021 and fix it if it is affected.

What it is: CVE-2026-45021 is a medium-severity vulnerability in kumahq kuma, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45021 in the wild and no public exploit code.

Affected product: kumahq kuma. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45021/ (Markdown: https://insights.sbomify.com/CVE-2026-45021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45021
- OSV: https://osv.dev/vulnerability/CVE-2026-45021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45021/
Summaries are generated and may contain mistakes; the official description above is the record.
