{"answers":{"affected":"2 open source packages ship an affected version, including @github/copilot. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45033 exists.","fix":"Upgrade @github/copilot to 1.0.43 or later.","what":"CVE-2026-45033 is a high-severity command injection vulnerability in github copilot-cli, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45033 and fix it if it is affected.\n\nWhat it is: CVE-2026-45033 is a high-severity command injection vulnerability in github copilot-cli, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45033 exists.\n\nAffected packages and fixed versions:\n- @github/copilot (npm): affected all versions; fixed in 1.0.43\n- @github/copilot (npm): affected all versions; fixed in 1.0.43\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45033/ (Markdown: https://insights.sbomify.com/CVE-2026-45033/index.md)","id":"CVE-2026-45033","markdown":"https://insights.sbomify.com/CVE-2026-45033/index.md","name":"CVE-2026-45033","record":{"aliases":["GHSA-9ccr-r5hg-74gf"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GitHub Copilot CLI","requires_auth":"low_privilege","summary":"A malicious nested bare git repository can trigger arbitrary command execution via git config keys during Copilot CLI operations.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"copilot-cli","vendor":"github"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-696","name":"Incorrect Behavior Order"}],"description":"GitHub Copilot CLI brings AI-powered coding assistance directly to your command line. Prior to 1.0.43, a  security vulnerability has been identified in GitHub Copilot CLI where a malicious bare git repository nested inside a project directory can achieve arbitrary code execution when the agent performs git operations. By exploiting git's automatic bare repository discovery during directory traversal, an attacker can set core.fsmonitor or other executable config keys to run arbitrary commands without user awareness or approval. The vulnerability arises because git's core.fsmonitor config key (and 15+ similar keys such as core.hookspath, diff.external, merge.tool, etc.) can specify arbitrary shell commands that git will execute as part of normal operations like status, diff, or rev-parse. This vulnerability is fixed in 1.0.43.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-08-04","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-04T08:18:17Z","kind":"github_poc","ref":"https://github.com/grassplatypus/cve-2026-45033-class","stars":0,"title":"CVE-2026-45033 PoC for Claude Code, not Github Copilot. Worked for Haiku 4.5."}],"tier":"weaponised"},"has_fix":true,"headline":"GitHub Copilot CLI: Nested Bare Repository Can Execute Arbitrary Commands via core.fsmonitor","id":"CVE-2026-45033","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"PhpSpreadsheet: File::prohibitWrappers bypass","id":"CVE-2026-45034"},"packages":[{"ecosystem":"npm","fixed":["1.0.43"],"introduced":["0"],"last_affected":[],"package":"@github/copilot","purl":null,"source":"GHSA-9ccr-r5hg-74gf"},{"ecosystem":"npm","fixed":["1.0.43"],"introduced":["0"],"last_affected":[],"package":"@github/copilot","purl":"pkg:npm/%40github/copilot","source":"GHSA-9ccr-r5hg-74gf"}],"prev":{"headline":"ImageMagick: Policy Bypass in PSD decoder","id":"CVE-2026-45031"},"products":["copilot-cli"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["github"]},"summary":"A malicious nested bare git repository can trigger arbitrary command execution via git config keys during Copilot CLI operations.","url":"https://insights.sbomify.com/CVE-2026-45033/"}