{"answers":{"affected":"2 open source packages ship an affected version, including phpoffice/phpspreadsheet.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45034 exists.","fix":"Upgrade phpoffice/phpspreadsheet to 1.30.5 or later.","what":"CVE-2026-45034 is a critical unsafe deserialization vulnerability in PHPOffice PhpSpreadsheet, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45034 and fix it if it is affected.\n\nWhat it is: CVE-2026-45034 is a critical unsafe deserialization vulnerability in PHPOffice PhpSpreadsheet, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45034 exists.\n\nAffected packages and fixed versions:\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.5\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45034/ (Markdown: https://insights.sbomify.com/CVE-2026-45034/index.md)","id":"CVE-2026-45034","markdown":"https://insights.sbomify.com/CVE-2026-45034/index.md","name":"CVE-2026-45034","record":{"aliases":["GHSA-87m4-826x-3crx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"none","summary":"Attackers can bypass wrapper restrictions to trigger unsafe deserialization in PhpSpreadsheet, leading to remote code execution on PHP 7.x or file reads on PHP 8.x.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.5, CVE-2026-34084 was patched by the helper File::prohibitWrappers. The helper calls parse_url($filename, PHP_URL_SCHEME) and then checks is_string($scheme) \u0026\u0026 strlen($scheme) \u003e 1 to reject stream wrappers such as phar://, php://, data:// or expect://. The check is not equivalent to \"does the path contain a wrapper\". When the input has the form phar:///path/file.phar/inner with three or more slashes after the scheme, parse_url returns boolean false instead of returning the scheme string. The is_string($scheme) branch is therefore skipped, the helper returns without throwing, and the caller proceeds. PHP's stream layer, however, still treats phar:///... as a valid phar wrapper and opens the underlying phar file. The result is that IOFactory::load($attackerPath) walks past the patch and still touches the phar wrapper. On PHP 7.x, simply reaching the phar wrapper via is_file is enough for PHP to automatically deserialize the phar metadata, which in turn invokes the magic methods __wakeup and __destruct of an attacker controlled object and gives full RCE. On PHP 8.x, automatic metadata deserialization for plain file ops was removed, so the chain at the PhpSpreadsheet layer reduces to a phar wrapper file read primitive, and RCE only resurfaces if the downstream consumer ever calls Phar::getMetadata. This vulnerability is fixed in 1.30.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-06-11","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-11T06:47:06Z","kind":"github_poc","ref":"https://github.com/SangSenimanWartefak/CVE-2026-45034","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"PhpSpreadsheet: File::prohibitWrappers bypass","id":"CVE-2026-45034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Tabby: RCE via `tabby://run` URL Scheme","id":"CVE-2026-45035"},"packages":[{"ecosystem":"Packagist","fixed":["1.30.5"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-87m4-826x-3crx"},{"ecosystem":"Packagist","fixed":["1.30.5"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-87m4-826x-3crx"}],"prev":{"headline":"GitHub Copilot CLI: Nested Bare Repository Can Execute Arbitrary Commands via core.fsmonitor","id":"CVE-2026-45033"},"products":["PhpSpreadsheet"],"published":"2026-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["PHPOffice"]},"summary":"Attackers can bypass wrapper restrictions to trigger unsafe deserialization in PhpSpreadsheet, leading to remote code execution on PHP 7.x or file reads on PHP 8.x.","url":"https://insights.sbomify.com/CVE-2026-45034/"}