# CVE-2026-45036: Command injection in tabby

> Tabby terminal emulator allows remote code execution via crafted file content due to automatic ZMODEM protocol confirmation injecting shell commands.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-qr3x-j8g9-xhf6

## What is CVE-2026-45036?

CVE-2026-45036 is a high-severity command injection vulnerability in Eugeny tabby, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.233, Tabby before 1.0.233 automatically confirms ZMODEM protocol detection on all terminal session output without user interaction, enabling shell command execution when a user displays attacker-controlled content. The ZModemMiddleware in tabby-terminal consumes all session output through a Zmodem.Sentry, and when a ZMODEM ZRQINIT header is detected, unconditionally calls detection.confirm() and writes a fixed ZRINIT response ( **\x18B0100000023be50\r\n\x11) back into the active PTY as input. When the process that triggered the detection (e.g., cat) exits, the injected bytes are consumed by the user's shell as a command line. Under fish (default configuration), the ** prefix triggers recursive glob expansion against the current directory, allowing an attacker-placed executable at a matching nested path (e.g., d/xB0100000023be50) to be executed by relative pathname without relying on PATH. Under bash and zsh, a secondary xterm.js terminal color-query feedback (OSC 10) can be combined in the same file to inject a slash-containing command word that similarly bypasses PATH resolution. An attacker can exploit this by providing a crafted file (e.g., in a cloned Git repository) that a user displays with cat, achieving code execution with no interaction beyond viewing the file. This vulnerability is fixed in 1.0.233.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-45036?

It affects 1 product.


Products: Tabby Tabby.

## How do I fix CVE-2026-45036?

No fix has been published for CVE-2026-45036 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45036 being exploited?

There is no known exploitation of CVE-2026-45036 in the wild and no public exploit code.

## Other vulnerabilities in Eugeny tabby

- [CVE-2026-45035](https://insights.sbomify.com/CVE-2026-45035/): Tabby: RCE via `tabby://run` URL Scheme (critical 9.4)
- [CVE-2026-45038](https://insights.sbomify.com/CVE-2026-45038/): Tabby: Dragging and Dropping a File into Tabby Can Lead to Code Execution (high 8.4)
- [CVE-2026-46709](https://insights.sbomify.com/CVE-2026-46709/): Tabby: Drag-and-drop path injection still allows RCE via shell command substitution (incomplete fix for CVE-2026-45038) (high 7.8)
- [CVE-2026-45037](https://insights.sbomify.com/CVE-2026-45037/): Tabby: Unsafe protocol handler execution via terminal linkifier allows arbitrary OS protocol invocation (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45036 and fix it if it is affected.

What it is: CVE-2026-45036 is a high-severity command injection vulnerability in Eugeny tabby, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45036 in the wild and no public exploit code.

Affected product: Eugeny tabby. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45036/ (Markdown: https://insights.sbomify.com/CVE-2026-45036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45036
- OSV: https://osv.dev/vulnerability/CVE-2026-45036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45036/
Summaries are generated and may contain mistakes; the official description above is the record.
