# CVE-2026-45038: Tabby: Dragging and Dropping a File into Tabby Can Lead to Code Execution

> Attackers can execute arbitrary code by tricking users into dragging and dropping maliciously named files into the Tabby terminal emulator.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-m937-jm93-pfp6

## What is CVE-2026-45038?

CVE-2026-45038 is a high-severity command injection vulnerability in Eugeny tabby, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.233, since Tabby does not escape control characters from file paths when dragging and dropping a file into it, code execution can be achieved. This vulnerability is fixed in 1.0.233.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-45038?

It affects 1 product.


Products: Tabby Tabby.

## How do I fix CVE-2026-45038?

No fix has been published for CVE-2026-45038 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45038 being exploited?

There is no known exploitation of CVE-2026-45038 in the wild and no public exploit code.

## Other vulnerabilities in Eugeny tabby

- [CVE-2026-45035](https://insights.sbomify.com/CVE-2026-45035/): Tabby: RCE via `tabby://run` URL Scheme (critical 9.4)
- [CVE-2026-46709](https://insights.sbomify.com/CVE-2026-46709/): Tabby: Drag-and-drop path injection still allows RCE via shell command substitution (incomplete fix for CVE-2026-45038) (high 7.8)
- [CVE-2026-45037](https://insights.sbomify.com/CVE-2026-45037/): Tabby: Unsafe protocol handler execution via terminal linkifier allows arbitrary OS protocol invocation (high 7.1)
- [CVE-2026-45036](https://insights.sbomify.com/CVE-2026-45036/): Command injection in tabby (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45038 and fix it if it is affected.

What it is: CVE-2026-45038 is a high-severity command injection vulnerability in Eugeny tabby, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45038 in the wild and no public exploit code.

Affected product: Eugeny tabby. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45038/ (Markdown: https://insights.sbomify.com/CVE-2026-45038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45038
- OSV: https://osv.dev/vulnerability/CVE-2026-45038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45038/
Summaries are generated and may contain mistakes; the official description above is the record.
