# CVE-2026-45048: OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC

> Authenticated users can escalate privileges and hijack sessions by retrieving other users' credentials via session RPC in stateful deployments.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-vvhj-w2jq-263q, UBUNTU-CVE-2026-45048

## What is CVE-2026-45048?

CVE-2026-45048 is a high-severity vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, SessionRequestHandler in the session management endpoint does not enforce ownership or privilege checks when a low-privileged authenticated user queries session information in deployments using stateful session storage. A requester who knows a target identity identifier can retrieve another user's active session credentials, including credentials for a more privileged account, and use them to hijack that session. This issue is fixed in version 16.1.1.

Weakness: CWE-285 (Improper Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-45048?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-core` | Maven | All versions | 16.1.1 |
| `org.openidentityplatform.openam:openam-core` | Maven | All versions | 16.1.1 |

## How do I fix CVE-2026-45048?

Upgrade org.openidentityplatform.openam:openam-core to 16.1.1 or later.

## Is CVE-2026-45048 being exploited?

There is no known exploitation of CVE-2026-45048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45048 and fix it if it is affected.

What it is: CVE-2026-45048 is a high-severity vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45048 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1
- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45048/ (Markdown: https://insights.sbomify.com/CVE-2026-45048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45048
- OSV: https://osv.dev/vulnerability/CVE-2026-45048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45048/
Summaries are generated and may contain mistakes; the official description above is the record.
