# CVE-2026-45055: CubeCart: Pre-Authenticated Password Reset Link Poisoning via HTTP Host Header

> Attackers can poison password reset links via Host header injection, leading to account takeover when victims click malicious links.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-7pvc-gxc4-chmc

## What is CVE-2026-45055?

CVE-2026-45055 is a high-severity vulnerability in cubecart v6, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CubeCart is an ecommerce software solution. Prior to 6.7.2, CubeCart 6.6.x – 6.7.1 builds CC_STORE_URL directly from the Host request header at bootstrap, with no allowlist. The constant is embedded verbatim into transactional email links, most critically the password-reset link in User::passwordRequest() (and the admin equivalent in Admin::passwordRequest()). An unauthenticated attacker who knows a target email can POST /index.php?_a=recover with Host: evil.com; CubeCart writes a fresh verify token (valid 3,600 s) and emails the victim a link http://evil.com/index.php?_a=recovery&validate=<TOKEN>. The token is valid against the legitimate store — capturing the victim's click on evil.com yields full account takeover, or store takeover when an admin email is targeted. This vulnerability is fixed in 6.7.2.

Weakness: CWE-784 (Reliance on Cookies without Validation and Integrity Checking in a Security Decision), CWE-601 (URL Redirection to Untrusted Site), CWE-345 (Insufficient Verification of Data Authenticity), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-45055?


## How do I fix CVE-2026-45055?

No fix has been published for CVE-2026-45055 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45055 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45055 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45055 and fix it if it is affected.

What it is: CVE-2026-45055 is a high-severity vulnerability in cubecart v6, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45055 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45055/ (Markdown: https://insights.sbomify.com/CVE-2026-45055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45055
- OSV: https://osv.dev/vulnerability/CVE-2026-45055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45055/
Summaries are generated and may contain mistakes; the official description above is the record.
