# CVE-2026-45060: ClipBucket: Blind SQL Injection in progress_video.php

> Unauthenticated attackers can exploit blind SQL injection in ClipBucket to exfiltrate sensitive data from the database.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jun 2026
- **Updated:** 12 Jun 2026

## What is CVE-2026-45060?

CVE-2026-45060 is a critical SQL injection vulnerability in MacWarrior clipbucket-v5, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ClipBucket v5 is an open source video sharing platform. Prior to version 5.5.3 - #129, the actions/progress_video.php endpoint is vulnerable to blind SQL injection. Any unauthenticated user can exploit the ids parameter to execute SQL queries and exfiltrate sensitive data. This issue has been patched in version 5.5.3 - #129.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-45060?


## How do I fix CVE-2026-45060?

No fix has been published for CVE-2026-45060 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45060 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45060 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45060 and fix it if it is affected.

What it is: CVE-2026-45060 is a critical SQL injection vulnerability in MacWarrior clipbucket-v5, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45060 exists.

Affected product: MacWarrior clipbucket-v5. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45060/ (Markdown: https://insights.sbomify.com/CVE-2026-45060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45060
- OSV: https://osv.dev/vulnerability/CVE-2026-45060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45060/
Summaries are generated and may contain mistakes; the official description above is the record.
