{"answers":{"affected":"2 open source packages ship an affected version, including budibase.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45061 exists.","fix":"Upgrade budibase to 3.35.10 or later.","what":"CVE-2026-45061 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45061 and fix it if it is affected.\n\nWhat it is: CVE-2026-45061 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45061 exists.\n\nAffected packages and fixed versions:\n- budibase (npm): affected all versions; fixed in 3.35.10\n- budibase (npm): affected all versions; fixed in 3.35.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45061/ (Markdown: https://insights.sbomify.com/CVE-2026-45061/index.md)","id":"CVE-2026-45061","markdown":"https://insights.sbomify.com/CVE-2026-45061/index.md","name":"CVE-2026-45061","record":{"aliases":["GHSA-xh5j-727m-w6gg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Budibase low-code platform","requires_auth":"low_privilege","summary":"Attackers can bypass URL validation to perform Server-Side Request Forgery, potentially accessing internal resources if blacklist protections are disabled or bypassed.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Budibase is an open-source low-code platform. Prior to 3.35.10, the Plugin URL upload endpoint (POST /api/plugin) validates the submitted URL with a single substring check: url.includes(\".tar.gz\"). Any URL containing .tar.gz anywhere in the string — in the path, query string, or fragment — passes this check. The URL then proceeds directly to fetchWithBlacklist() with no further validation of host, scheme, or path. Standalone, this vulnerability is blocked by Budibase's default SSRF blacklist, which covers private IP ranges. But the URL validation layer itself is broken regardless, and it directly enables SSRF in two realistic situations: (1) when chained with the BLACKLIST_IPS bypass ([001]), where the blacklist is empty; and (2) when the plugin server follows HTTP redirects from an external URL to an internal target (the default node-fetch behavior with redirect: 'follow'). This vulnerability is fixed in 3.35.10.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Budibase: SSRF via trivial `.tar.gz` substring bypass in Plugin URL upload (`/api/plugin`)","id":"CVE-2026-45061","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"FrankenPHP: Unsafe Unicode Handling in CGI Path Splitting Allows Execution of Non-PHP Files","id":"CVE-2026-45062"},"packages":[{"ecosystem":"npm","fixed":["3.35.10"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":null,"source":"GHSA-xh5j-727m-w6gg"},{"ecosystem":"npm","fixed":["3.35.10"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":"pkg:npm/budibase","source":"GHSA-xh5j-727m-w6gg"}],"prev":{"headline":"ClipBucket: Blind SQL Injection in progress_video.php","id":"CVE-2026-45060"},"products":["budibase"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["Budibase"]},"summary":"Attackers can bypass URL validation to perform Server-Side Request Forgery, potentially accessing internal resources if blacklist protections are disabled or bypassed.","url":"https://insights.sbomify.com/CVE-2026-45061/"}