CVE-2026-45065 Symfony: UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection

Low 2.3 Published Updated

Attackers can bypass route validation to generate protocol-relative off-site URLs, enabling open redirects in Symfony applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-45065?

CVE-2026-45065 is a low-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, UrlGenerator validates route parameters against a pattern built as ^ plus the raw requirement plus $; with ungrouped alternations, middle alternatives match as unanchored substrings, allowing a value such as //evil.com to satisfy a common locale requirement and generate a protocol-relative off-site URL. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Weakness: CWE-601, CWE-185

Which versions are affected by CVE-2026-45065?

16 open source packages ship an affected version, including symfony/routing and symfony/symfony. It affects 1 product.

PackageAffectedFixed in
symfony/routing PackagistAll versions5.4.52
symfony/routing PackagistAll versions5.4.52
symfony/routing PackagistFrom 6.0.06.4.40
symfony/routing PackagistFrom 6.0.06.4.40
symfony/routing PackagistFrom 7.0.07.4.12
symfony/routing PackagistFrom 7.0.07.4.12
10 more packages
symfony/routing PackagistFrom 8.0.08.0.12
symfony/routing PackagistFrom 8.0.08.0.12
symfony/symfony PackagistAll versions5.4.52
symfony/symfony PackagistAll versions5.4.52
symfony/symfony PackagistFrom 6.0.06.4.40
symfony/symfony PackagistFrom 6.0.06.4.40
symfony/symfony PackagistFrom 7.0.07.4.12
symfony/symfony PackagistFrom 7.0.07.4.12
symfony/symfony PackagistFrom 8.0.08.0.12
symfony/symfony PackagistFrom 8.0.08.0.12

Products include Sensiolabs Symfony.

How do I fix CVE-2026-45065?

Upgrade symfony/routing to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.

Is CVE-2026-45065 being exploited?

There is no known exploitation of CVE-2026-45065 in the wild and no public exploit code.

All Sensiolabs Symfony vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-45065, GHSA-72xp-p242-47p9, UBUNTU-CVE-2026-45065.

Is CVE-2026-45065 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free