# CVE-2026-45065: Symfony: UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection

> Attackers can bypass route validation to generate protocol-relative off-site URLs, enabling open redirects in Symfony applications.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-45065, GHSA-72xp-p242-47p9, UBUNTU-CVE-2026-45065

## What is CVE-2026-45065?

CVE-2026-45065 is a low-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, UrlGenerator validates route parameters against a pattern built as ^ plus the raw requirement plus $; with ungrouped alternations, middle alternatives match as unanchored substrings, allowing a value such as //evil.com to satisfy a common locale requirement and generate a protocol-relative off-site URL. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2026-45065?

16 open source packages ship an affected version, including symfony/routing and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/routing` | Packagist | All versions | 5.4.52 |
| `symfony/routing` | Packagist | All versions | 5.4.52 |
| `symfony/routing` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/routing` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/routing` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/routing` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/routing` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/routing` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | All versions | 5.4.52 |
| `symfony/symfony` | Packagist | All versions | 5.4.52 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.40 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2026-45065?

Upgrade symfony/routing to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.

## Is CVE-2026-45065 being exploited?

There is no known exploitation of CVE-2026-45065 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45065 and fix it if it is affected.

What it is: CVE-2026-45065 is a low-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45065 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/routing (Packagist): affected all versions; fixed in 5.4.52
- symfony/routing (Packagist): affected all versions; fixed in 5.4.52
- symfony/routing (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/routing (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/routing (Packagist): affected from 7.0.0; fixed in 7.4.12
- symfony/routing (Packagist): affected from 7.0.0; fixed in 7.4.12
- symfony/routing (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/routing (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.52
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.52
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.40
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45065/ (Markdown: https://insights.sbomify.com/CVE-2026-45065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45065
- OSV: https://osv.dev/vulnerability/CVE-2026-45065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45065/
Summaries are generated and may contain mistakes; the official description above is the record.
