CVE-2026-45068 Symfony: Argument Injection in SendmailTransport via Dash-Prefixed Recipient Address
Attackers can inject sendmail command-line options via dash-prefixed recipient addresses, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45068?
CVE-2026-45068 is a high-severity command injection vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, SendmailTransport in -t mode appended recipient addresses to the sendmail command line without a -- end-of-options separator, allowing an address beginning with - to be interpreted as a sendmail command-line option instead of an address. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Weakness: CWE-88
Which versions are affected by CVE-2026-45068?
16 open source packages ship an affected version, including symfony/mailer and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/mailer Packagist | All versions | 5.4.52 |
symfony/mailer Packagist | All versions | 5.4.52 |
symfony/mailer Packagist | From 6.0.0 | 6.4.40 |
symfony/mailer Packagist | From 6.0.0 | 6.4.40 |
symfony/mailer Packagist | From 7.0.0 | 7.4.12 |
symfony/mailer Packagist | From 7.0.0 | 7.4.12 |
10 more packages
symfony/mailer Packagist | From 8.0.0 | 8.0.12 |
symfony/mailer Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | All versions | 5.4.52 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 6.0.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45068?
Upgrade symfony/mailer to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-45068 being exploited?
There is no known exploitation of CVE-2026-45068 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1782867601, CLSA-2026-1783645408, DEBIAN-CVE-2026-45068, GHSA-xx3c-qf5g-hc39, UBUNTU-CVE-2026-45068.