CVE-2026-45069 Symfony: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims
Attackers can bypass authentication in Symfony applications by using JWTs missing mandatory claims, as the token handler fails to enforce their presence.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45069?
CVE-2026-45069 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 6.4.40, 7.4.12, and 8.0.12, OidcTokenHandler::verifyClaims() registered audience (aud), issuer (iss), and expiry (exp) checkers but did not pass the mandatory claims list to ClaimCheckerManager::check(), so a validly signed JWT that omitted those claims could pass verification. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.
Which versions are affected by CVE-2026-45069?
12 open source packages ship an affected version, including symfony/security-http and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security-http Packagist | From 6.3.0 | 6.4.40 |
symfony/security-http Packagist | From 6.3.0 | 6.4.40 |
symfony/security-http Packagist | From 7.4.0 | 7.4.12 |
symfony/security-http Packagist | From 7.4.0 | 7.4.12 |
symfony/security-http Packagist | From 8.0.0 | 8.0.12 |
symfony/security-http Packagist | From 8.0.0 | 8.0.12 |
6 more packages
symfony/symfony Packagist | From 6.3.0 | 6.4.40 |
symfony/symfony Packagist | From 6.3.0 | 6.4.40 |
symfony/symfony Packagist | From 7.4.0 | 7.4.12 |
symfony/symfony Packagist | From 7.4.0 | 7.4.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45069?
Upgrade symfony/security-http to a fixed version for your release line: 6.4.40, 7.4.12 or 8.0.12.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-45069 being exploited?
There is no known exploitation of CVE-2026-45069 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2026-45069, GHSA-29fc-p6c4-24cg, UBUNTU-CVE-2026-45069.