CVE-2026-45070 Symfony: Email Header Injection via Non-Token Characters in Mime Parameter Names

Medium 6.3 Published Updated

Attackers can inject arbitrary headers into emails by exploiting unvalidated parameter names in Symfony's MIME component, potentially altering email structure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45070?

CVE-2026-45070 is a medium-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Mime\Header\ParameterizedHeader validates and encodes parameter values but emits parameter names verbatim, allowing a caller that derives a parameter name from untrusted input to include CRLF or other non-token bytes and inject additional headers into rendered structured mail headers such as Content-Type or Content-Disposition. This issue is reported as fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Weakness: CWE-93

Which versions are affected by CVE-2026-45070?

16 open source packages ship an affected version, including symfony/mime and symfony/symfony. It affects 1 product.

PackageAffectedFixed in
symfony/mime PackagistAll versions5.4.52
symfony/mime PackagistAll versions5.4.52
symfony/mime PackagistFrom 6.0.06.4.40
symfony/mime PackagistFrom 6.0.06.4.40
symfony/mime PackagistFrom 7.0.07.4.12
symfony/mime PackagistFrom 7.0.07.4.12
10 more packages
symfony/mime PackagistFrom 8.0.08.0.12
symfony/mime PackagistFrom 8.0.08.0.12
symfony/symfony PackagistAll versions5.4.52
symfony/symfony PackagistAll versions5.4.52
symfony/symfony PackagistFrom 6.0.06.4.40
symfony/symfony PackagistFrom 6.0.06.4.40
symfony/symfony PackagistFrom 7.0.07.4.12
symfony/symfony PackagistFrom 7.0.07.4.12
symfony/symfony PackagistFrom 8.0.08.0.12
symfony/symfony PackagistFrom 8.0.08.0.12

Products include Sensiolabs Symfony.

How do I fix CVE-2026-45070?

Upgrade symfony/mime to a fixed version for your release line: 5.4.52, 6.4.40, 7.4.12 or 8.0.12.

Is CVE-2026-45070 being exploited?

There is no known exploitation of CVE-2026-45070 in the wild and no public exploit code.

All Sensiolabs Symfony vulnerabilities

Sources

Also known as CLSA-2026-1783386119, DEBIAN-CVE-2026-45070, GHSA-vqc8-7275-q272, UBUNTU-CVE-2026-45070.

Is CVE-2026-45070 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free