CVE-2026-45075 Symfony: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]
Attackers can bypass GET-only security checks by sending HEAD requests, allowing protected controllers to execute and leak headers or perform side effects.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45075?
CVE-2026-45075 is a high-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.
Weakness: CWE-863
Which versions are affected by CVE-2026-45075?
12 open source packages ship an affected version, including symfony/http-kernel, symfony/security-http and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-kernel Packagist | From 7.4.0 | 7.4.12 |
symfony/http-kernel Packagist | From 7.4.0 | 7.4.12 |
symfony/http-kernel Packagist | From 8.0.0 | 8.0.12 |
symfony/http-kernel Packagist | From 8.0.0 | 8.0.12 |
symfony/security-http Packagist | From 7.4.0 | 7.4.12 |
symfony/security-http Packagist | From 7.4.0 | 7.4.12 |
6 more packages
symfony/security-http Packagist | From 8.0.0 | 8.0.12 |
symfony/security-http Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 7.4.0 | 7.4.12 |
symfony/symfony Packagist | From 7.4.0 | 7.4.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-45075?
Upgrade symfony/http-kernel to a fixed version for your release line: 7.4.12 or 8.0.12.
Is CVE-2026-45075 being exploited?
There is no known exploitation of CVE-2026-45075 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as CLSA-2026-1783645391, DEBIAN-CVE-2026-45075, GHSA-6439-2f28-8p8q, UBUNTU-CVE-2026-45075.