# CVE-2026-45075: Symfony: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]

> Attackers can bypass GET-only security checks by sending HEAD requests, allowing protected controllers to execute and leak headers or perform side effects.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** CLSA-2026-1783645391, DEBIAN-CVE-2026-45075, GHSA-6439-2f28-8p8q, UBUNTU-CVE-2026-45075

## What is CVE-2026-45075?

CVE-2026-45075 is a high-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-45075?

12 open source packages ship an affected version, including symfony/http-kernel, symfony/security-http and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-kernel` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/http-kernel` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/http-kernel` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/http-kernel` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/security-http` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/security-http` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/security-http` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/security-http` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 7.4.0 | 7.4.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.12 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2026-45075?

Upgrade symfony/http-kernel to a fixed version for your release line: 7.4.12 or 8.0.12.

## Is CVE-2026-45075 being exploited?

There is no known exploitation of CVE-2026-45075 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45075 and fix it if it is affected.

What it is: CVE-2026-45075 is a high-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45075 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/http-kernel (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/http-kernel (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/http-kernel (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/http-kernel (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/security-http (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/security-http (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/security-http (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/security-http (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 7.4.0; fixed in 7.4.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45075/ (Markdown: https://insights.sbomify.com/CVE-2026-45075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45075
- OSV: https://osv.dev/vulnerability/CVE-2026-45075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45075/
Summaries are generated and may contain mistakes; the official description above is the record.
