# CVE-2026-45076: Synapse pagination denial of service

> Malicious homeservers can prevent Synapse from providing full history to clients, causing a denial of service for room history display.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-6qf2-7x63-mm6v, PYSEC-2026-194, UBUNTU-CVE-2026-45076

## What is CVE-2026-45076?

CVE-2026-45076 is a medium-severity denial of service vulnerability in element-hq synapse, published on 28 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Synapse is an open source Matrix homeserver implementation. Prior to 1.152.1, in federated rooms, malicious homeservers can craft room events in such a way that prevents Synapse from providing full history to paginating clients. Clients could therefore fail to display room history. This vulnerability is fixed in 1.152.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-45076?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |

Products: Element Synapse.

## How do I fix CVE-2026-45076?

Upgrade matrix-synapse to 1.152.1 or later.

## Is CVE-2026-45076 being exploited?

There is no known exploitation of CVE-2026-45076 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2026-45078](https://insights.sbomify.com/CVE-2026-45078/): Synapse CPU starvation (Denial of Service) (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45076 and fix it if it is affected.

What it is: CVE-2026-45076 is a medium-severity denial of service vulnerability in element-hq synapse, published on 28 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45076 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45076/ (Markdown: https://insights.sbomify.com/CVE-2026-45076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45076
- OSV: https://osv.dev/vulnerability/CVE-2026-45076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45076/
Summaries are generated and may contain mistakes; the official description above is the record.
