# CVE-2026-45078: Synapse CPU starvation (Denial of Service)

> Authenticated users can cause CPU starvation in Synapse, denying service to other users; administrators should upgrade to the fixed version.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-8q93-326v-3m7g, PYSEC-2026-191, UBUNTU-CVE-2026-45078

## What is CVE-2026-45078?

CVE-2026-45078 is a medium-severity denial of service vulnerability in element-hq synapse, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Synapse is an open source Matrix homeserver implementation. Prior to 1.152.1, local authenticated users can cause Synapse to starve other requests of CPU and lead to other requests failing, causing other users to be denied service. This vulnerability is fixed in 1.152.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-45078?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |
| `matrix-synapse` | PyPI | All versions | 1.152.1 |

Products: Element Synapse.

## How do I fix CVE-2026-45078?

Upgrade matrix-synapse to 1.152.1 or later.

## Is CVE-2026-45078 being exploited?

There is no known exploitation of CVE-2026-45078 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2026-45076](https://insights.sbomify.com/CVE-2026-45076/): Synapse pagination denial of service (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45078 and fix it if it is affected.

What it is: CVE-2026-45078 is a medium-severity denial of service vulnerability in element-hq synapse, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45078 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.152.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45078/ (Markdown: https://insights.sbomify.com/CVE-2026-45078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45078
- OSV: https://osv.dev/vulnerability/CVE-2026-45078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45078/
Summaries are generated and may contain mistakes; the official description above is the record.
