# CVE-2026-45081: Frappe HR: Permission Bypass in HRMS Leave Details API

> Authenticated employees can access other employees' leave details due to improper authorization checks in Frappe HRMS.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-9jpf-5vrm-hpcj

## What is CVE-2026-45081?

CVE-2026-45081 is a medium-severity missing authorization vulnerability in frappe hrms, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe HR is an open-source human resources management solution (HRMS). Prior to 16.5.0, authenticated employees could access other employees’ leave details due to improper authorization checks. This vulnerability is fixed in 16.5.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-45081?


## How do I fix CVE-2026-45081?

No fix has been published for CVE-2026-45081 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45081 being exploited?

There is no known exploitation of CVE-2026-45081 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45081 and fix it if it is affected.

What it is: CVE-2026-45081 is a medium-severity missing authorization vulnerability in frappe hrms, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45081 in the wild and no public exploit code.

Affected product: frappe hrms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45081/ (Markdown: https://insights.sbomify.com/CVE-2026-45081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45081
- OSV: https://osv.dev/vulnerability/CVE-2026-45081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45081/
Summaries are generated and may contain mistakes; the official description above is the record.
