CVE-2026-45084 OpenSIPS: Denial of service in presence.handle_publish() from unchecked Content-Type state
Remote attackers can crash OpenSIPS via crafted SIP PUBLISH requests when sphere checks are enabled, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-45084?
CVE-2026-45084 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions 3.4.0 through 3.6.5 contain a denial of service vulnerability in the presence module. When the presence module's handle_publish() function processes a SIP PUBLISH request with an Event: presence header and a message body while the configuration option enable_sphere_check=1 is set, it invokes the get_content_type() macro without first calling parse_content_type_hdr(), causing it to dereference uninitialized or NULL Content-Type parsing state and crash. If a Content-Type header is present but unparsed, msg->content_type->parsed is NULL and is dereferenced as a content_t pointer; if the request lacks a Content-Type header entirely, msg->content_type itself is NULL, and both cases lead to a crash. A remote attacker can therefore cause a denial of service against an affected instance with a single PUBLISH request over UDP or TCP, using either a valid Content-Type: application/pidf+xml request or one with the header removed, and the vulnerable code path itself does not enforce authentication (though a deployment's routing configuration may require it before this route is reached). The issue has been fixed in version 3.6.6 and 4.0.0-rc1.
Weakness: CWE-476
Which versions are affected by CVE-2026-45084?
How do I fix CVE-2026-45084?
No fix has been published for CVE-2026-45084 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-45084 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45084 exists.
Sources
Also known as GHSA-h3ww-hchh-x2g9, UBUNTU-CVE-2026-45084.