CVE-2026-45086 Decidim: Forms admin question editor lacks authorization
A normal participant can access the admin demographics questionnaire editor without authorization, allowing unauthorized viewing and potential modification of form data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45086?
CVE-2026-45086 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Decidim is a participatory democracy framework. From 0.31.1 before 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, a participant can directly load /admin/demographics/questions/edit_questions and reach the demographics questionnaire editor without the required administrator authorization. The demographics questionnaire editor should require admin access, but the route under /admin/demographics/questions renders the editor interface without checking whether the caller is an admin. A normal participant can load the page and see the live update form action, which proves the protected interface is reachable. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.
Weakness: CWE-862
Which versions are affected by CVE-2026-45086?
4 open source packages ship an affected version, including decidim-demographics.
| Package | Affected | Fixed in |
|---|---|---|
decidim-demographics RubyGems | From 0.31.0 | 0.31.5 |
decidim-demographics RubyGems | From 0.31.0 | 0.31.5 |
decidim-demographics RubyGems | From 0.32.0.rc1 | 0.32.0 |
decidim-demographics RubyGems | From 0.32.0.rc1 | 0.32.0 |
How do I fix CVE-2026-45086?
Upgrade decidim-demographics to a fixed version for your release line: 0.31.5 or 0.32.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-45086 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45086 exists.
Sources
Also known as GHSA-vq6j-hj8w-7v39.