{"answers":{"affected":"4 open source packages ship an affected version, including decidim-demographics.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45086 exists.","fix":"Upgrade decidim-demographics to a fixed version for your release line: 0.31.5 or 0.32.0.","what":"CVE-2026-45086 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45086 and fix it if it is affected.\n\nWhat it is: CVE-2026-45086 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45086 exists.\n\nAffected packages and fixed versions:\n- decidim-demographics (RubyGems): affected from 0.31.0; fixed in 0.31.5\n- decidim-demographics (RubyGems): affected from 0.31.0; fixed in 0.31.5\n- decidim-demographics (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n- decidim-demographics (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45086/ (Markdown: https://insights.sbomify.com/CVE-2026-45086/index.md)","id":"CVE-2026-45086","markdown":"https://insights.sbomify.com/CVE-2026-45086/index.md","name":"CVE-2026-45086","record":{"aliases":["GHSA-vq6j-hj8w-7v39"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"low_privilege","summary":"A normal participant can access the admin demographics questionnaire editor without authorization, allowing unauthorized viewing and potential modification of form data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Decidim is a participatory democracy framework. From 0.31.1 before 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, a participant can directly load /admin/demographics/questions/edit_questions and reach the demographics questionnaire editor without the required administrator authorization. The demographics questionnaire editor should require admin access, but the route under /admin/demographics/questions renders the editor interface without checking whether the caller is an admin. A normal participant can load the page and see the live update form action, which proves the protected interface is reachable. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Decidim: Forms admin question editor lacks authorization","id":"CVE-2026-45086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Dalfox: Unauthenticated Remote Code Execution via `found-action` in Dalfox Server Mode","id":"CVE-2026-45087"},"packages":[{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0"],"last_affected":[],"package":"decidim-demographics","purl":null,"source":"GHSA-vq6j-hj8w-7v39"},{"ecosystem":"RubyGems","fixed":["0.31.5"],"introduced":["0.31.0"],"last_affected":[],"package":"decidim-demographics","purl":"pkg:gem/decidim-demographics","source":"GHSA-vq6j-hj8w-7v39"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-demographics","purl":null,"source":"GHSA-vq6j-hj8w-7v39"},{"ecosystem":"RubyGems","fixed":["0.32.0"],"introduced":["0.32.0.rc1"],"last_affected":[],"package":"decidim-demographics","purl":"pkg:gem/decidim-demographics","source":"GHSA-vq6j-hj8w-7v39"}],"prev":{"headline":"Discourse: Chat misauthorization and information disclosure","id":"CVE-2026-45085"},"products":["decidim"],"published":"2026-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-03","vendors":["decidim"]},"summary":"A normal participant can access the admin demographics questionnaire editor without authorization, allowing unauthorized viewing and potential modification of form data.","url":"https://insights.sbomify.com/CVE-2026-45086/"}