# CVE-2026-45086: Decidim: Forms admin question editor lacks authorization

> A normal participant can access the admin demographics questionnaire editor without authorization, allowing unauthorized viewing and potential modification of form data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-vq6j-hj8w-7v39

## What is CVE-2026-45086?

CVE-2026-45086 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Decidim is a participatory democracy framework. From 0.31.1 before 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, a participant can directly load /admin/demographics/questions/edit_questions and reach the demographics questionnaire editor without the required administrator authorization. The demographics questionnaire editor should require admin access, but the route under /admin/demographics/questions renders the editor interface without checking whether the caller is an admin. A normal participant can load the page and see the live update form action, which proves the protected interface is reachable. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-45086?

4 open source packages ship an affected version, including decidim-demographics.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-demographics` | RubyGems | From 0.31.0 | 0.31.5 |
| `decidim-demographics` | RubyGems | From 0.31.0 | 0.31.5 |
| `decidim-demographics` | RubyGems | From 0.32.0.rc1 | 0.32.0 |
| `decidim-demographics` | RubyGems | From 0.32.0.rc1 | 0.32.0 |

## How do I fix CVE-2026-45086?

Upgrade decidim-demographics to a fixed version for your release line: 0.31.5 or 0.32.0.

## Is CVE-2026-45086 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45086 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45086 and fix it if it is affected.

What it is: CVE-2026-45086 is a medium-severity missing authorization vulnerability in decidim, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45086 exists.

Affected packages and fixed versions:
- decidim-demographics (RubyGems): affected from 0.31.0; fixed in 0.31.5
- decidim-demographics (RubyGems): affected from 0.31.0; fixed in 0.31.5
- decidim-demographics (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0
- decidim-demographics (RubyGems): affected from 0.32.0.rc1; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45086/ (Markdown: https://insights.sbomify.com/CVE-2026-45086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45086
- OSV: https://osv.dev/vulnerability/CVE-2026-45086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45086/
Summaries are generated and may contain mistakes; the official description above is the record.
