# CVE-2026-45090: Dalfox: Unauthenticated Remote DoS via Closed-Channel Write in `ParameterAnalysis` (server mode)

> Unauthenticated attackers can crash the Dalfox server by triggering a panic via closed-channel writes during parameter analysis.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-2g4x-fq3j-cgq4, GO-2026-4999

## What is CVE-2026-45090?

CVE-2026-45090 is a high-severity denial of service vulnerability in hahwul dalfox, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dalfox is a powerful open-source XSS scanner and utility focused on automation. Prior to 2.13.0, ParameterAnalysis in pkg/scanning/parameterAnalysis.go runs two sequential worker stages that both write to the same results channel. The channel is correctly closed after the first stage completes (close(results) at line 438), but the second stage — which processes POST-body parameters (dp) — is then launched with the same already-closed channel as its output. When a scanned parameter is reflected, processParams executes results <- paramResult on the closed channel, triggering a Go runtime panic that crashes the entire dalfox process. In server mode, the crash is remotely triggerable by any unauthenticated caller who can reach the REST API, because the default configuration has no API key and the second stage activates whenever options.Data != "" (i.e., the attacker supplies the data field) and the target reflects at least one parameter. This vulnerability is fixed in 2.13.0.

Weakness: CWE-404 (Improper Resource Shutdown or Release), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-45090?

6 open source packages ship an affected version, including github.com/hahwul/dalfox and github.com/hahwul/dalfox/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hahwul/dalfox` | Go | All versions | None |
| `github.com/hahwul/dalfox` | Go | All versions to 1.2.2 | None |
| `github.com/hahwul/dalfox` | Go | All versions to 1.2.2 | None |
| `github.com/hahwul/dalfox/v2` | Go | All versions | 2.13.0 |
| `github.com/hahwul/dalfox/v2` | Go | All versions | 2.13.0 |
| `github.com/hahwul/dalfox/v2` | Go | All versions | 2.13.0 |

## How do I fix CVE-2026-45090?

Upgrade to a fixed version.

## Is CVE-2026-45090 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45090 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45090 and fix it if it is affected.

What it is: CVE-2026-45090 is a high-severity denial of service vulnerability in hahwul dalfox, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45090 exists.

Affected packages and fixed versions:
- github.com/hahwul/dalfox (Go): affected all versions; no fix listed
- github.com/hahwul/dalfox (Go): affected all versions up to 1.2.2; no fix listed
- github.com/hahwul/dalfox (Go): affected all versions up to 1.2.2; no fix listed
- github.com/hahwul/dalfox/v2 (Go): affected all versions; fixed in 2.13.0
- github.com/hahwul/dalfox/v2 (Go): affected all versions; fixed in 2.13.0
- github.com/hahwul/dalfox/v2 (Go): affected all versions; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45090/ (Markdown: https://insights.sbomify.com/CVE-2026-45090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45090
- OSV: https://osv.dev/vulnerability/CVE-2026-45090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45090/
Summaries are generated and may contain mistakes; the official description above is the record.
