CVE-2026-45100 OpenSIPS: Buffer Overflow in Base64 Encode Transformation

Critical 9.1 Published Updated

A remote attacker can trigger a buffer overflow in OpenSIPS via large SIP headers if the routing script uses base64 encoding, potentially leading to code execution or crashes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45100?

CVE-2026-45100 is a critical memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions 3.4.0-beta through 3.6.5 and 4.0.0-beta contain a buffer overflow in the {s.b64encode} string transformation. The size check for {s.b64encode} only verifies that the input fits within the 64 KB transformation buffer, but base64 encoding expands the data by roughly a third, so an input between about 49,153 and 65,535 bytes produces more output than the buffer can hold and overflows it by up to 21,844 bytes. Because these transformation buffers sit next to each other in memory and are reused for chained transformations, the overflow writes attacker-controlled data into the adjacent buffer and corrupts values used by later transformations processing the same SIP message. A remote attacker can trigger this by sending a SIP message with a large header value (roughly 50,000 bytes or more) when the routing script applies  {s.b64encode}  to attacker-controlled input, making exploitability dependent on the deployment's routing configuration. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-120

Which versions are affected by CVE-2026-45100?

How do I fix CVE-2026-45100?

No fix has been published for CVE-2026-45100 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-45100 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45100 exists.

Sources

Also known as GHSA-35fr-6rv9-vp68, UBUNTU-CVE-2026-45100.

Is CVE-2026-45100 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free