# CVE-2026-45103: OpenSIPS: SIP Message Smuggling via TCP Content-Length Integer Overflow

> Unauthenticated attackers can smuggle SIP messages via TCP Content-Length integer overflow, bypassing security policies and rate limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-jv35-555v-54jh, UBUNTU-CVE-2026-45103

## What is CVE-2026-45103?

CVE-2026-45103 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. In versions prior to 3.6.6 and 4.0.0-rc1, the TCP message framing layer parses the Content-Length header using unsigned int arithmetic with no overflow check. When an attacker sends a Content-Length value that overflows unsigned int (e.g., 4294967296), the framing layer computes a wrapped-around value (e.g., 0) and splits the TCP stream at the wrong boundary, causing the body of the first SIP message to be processed as a separate message and enabling SIP message smuggling. Because Content-Length is parsed in the transport layer before authentication, an unauthenticated, network-based attacker can smuggle arbitrary SIP messages over any TCP-based transport (proto_tcp, proto_tls, proto_ws, proto_wss) on any instance with TCP enabled, with no routing-script preconditions. This allows smuggled messages to bypass front-end SBC/proxy security policies, inherit the connection's authentication context, and evade rate limiting. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-45103?


## How do I fix CVE-2026-45103?

No fix has been published for CVE-2026-45103 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45103 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45103 and fix it if it is affected.

What it is: CVE-2026-45103 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45103 exists.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45103/ (Markdown: https://insights.sbomify.com/CVE-2026-45103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45103
- OSV: https://osv.dev/vulnerability/CVE-2026-45103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45103/
Summaries are generated and may contain mistakes; the official description above is the record.
