# CVE-2026-45106: Weblate: Stored HTML injection in editor search preview

> Attackers can inject malicious HTML into search previews, executing scripts in other users' browsers to potentially steal sessions or data.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-6wxc-8mgq-w26m, PYSEC-2026-3415

## What is CVE-2026-45106?

CVE-2026-45106 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Weblate is a web based localization tool. Prior to version 2026.5, Weblate's live search preview renders unit source and context as HTML without escaping. Any contributor whose content reaches those fields stores HTML and CSS that runs inside the authenticated editor of every user who runs a matching search. This issue has been patched in version 2026.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45106?

3 open source packages ship an affected version, including weblate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 2026.5 |
| `weblate` | PyPI | All versions | 2026.5 |
| `weblate` | PyPI | All versions | 2026.5 |

## How do I fix CVE-2026-45106?

Upgrade weblate to 2026.5 or later.

## Is CVE-2026-45106 being exploited?

There is no known exploitation of CVE-2026-45106 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45106 and fix it if it is affected.

What it is: CVE-2026-45106 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45106 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 2026.5
- weblate (PyPI): affected all versions; fixed in 2026.5
- weblate (PyPI): affected all versions; fixed in 2026.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45106/ (Markdown: https://insights.sbomify.com/CVE-2026-45106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45106
- OSV: https://osv.dev/vulnerability/CVE-2026-45106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45106/
Summaries are generated and may contain mistakes; the official description above is the record.
