CVE-2026-45112 Apache Thrift: Unbounded Read Leading to Denial of Service

Medium 6.9 Published Updated

Attackers can cause denial of service in applications using Apache Thrift Java bindings by triggering unbounded resource allocation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45112?

CVE-2026-45112 is a medium-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Java bindings.

This issue affects Apache Thrift: from 0.19.0 before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-770

Which versions are affected by CVE-2026-45112?

1 open source package ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiFrom 0.19.00.24.0

Products include Apache Thrift.

How do I fix CVE-2026-45112?

Upgrade thrift to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-45112 being exploited?

There is no known exploitation of CVE-2026-45112 in the wild and no public exploit code.

Sources

Also known as BIT-thrift-2026-45112, CLEANSTART-2026-DN30065, CLEANSTART-2026-QF48371, DEBIAN-CVE-2026-45112, GHSA-g9fj-fh28-776p, MINI-c889-qvgr-g62x and 1 more.

Is CVE-2026-45112 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free