# CVE-2026-45115: MyBB: Buddy/ignore list username XSS

> Attackers can inject JavaScript via crafted usernames in MyBB buddy/ignore lists, potentially leading to code execution or account takeover.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-p766-qqxv-rfc2

## What is CVE-2026-45115?

CVE-2026-45115 is a high-severity cross-site scripting vulnerability in mybb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

MyBB is free and open source forum software. Prior to 1.8.40, the Buddy/Ignore component does not sanitize usernames correctly, allowing attackers to perform JavaScript code injection through a specially crafted username. The User CP Buddy/Ignore list and the Select Buddies list in Private Messages pass usernames through htmlspecialchars_uni(), which may leave single quotes unescaped. The payload is triggered when a victim chooses Yes in Please Confirm while removing the username in usercp.php, or selects the username through the onclick handler in the xmlhttp.php Select Buddies popup. The uniquely identifying implementation details include Private Messages Select Buddies list, and unescaped single quotes. This issue is fixed in version 1.8.40.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45115?


## How do I fix CVE-2026-45115?

No fix has been published for CVE-2026-45115 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45115 being exploited?

There is no known exploitation of CVE-2026-45115 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45115 and fix it if it is affected.

What it is: CVE-2026-45115 is a high-severity cross-site scripting vulnerability in mybb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45115 in the wild and no public exploit code.

Affected product: mybb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45115/ (Markdown: https://insights.sbomify.com/CVE-2026-45115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45115
- OSV: https://osv.dev/vulnerability/CVE-2026-45115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45115/
Summaries are generated and may contain mistakes; the official description above is the record.
