# CVE-2026-45116: MyBB: Profile field type confusion XSS

> Attackers can inject stored JavaScript via malformed profile fields, leading to code execution and potential account takeover in MyBB forums.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-4p6g-p3qh-559v

## What is CVE-2026-45116?

CVE-2026-45116 is a high-severity cross-site scripting vulnerability in mybb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

MyBB is free and open source forum software. Prior to 1.8.40, the user datahandler does not properly validate checkbox and multiselect profile field types, resulting in stored JavaScript code injection. UserDataHandler::verify_profile_fields() only performs the specialized validation when is_array($profile_fields[$field]) is true. A non-array profile_fields[fidX] value instead of the expected profile_fields[fidX][] shape falls through to generic text handling and is stored without verification. The affected value is then rendered directly by member.php and inc/functions_post.php rather than processed by the MyCode parser. The uniquely identifying implementation details include inc/datahandlers/user.php. This issue is fixed in version 1.8.40.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-45116?


## How do I fix CVE-2026-45116?

No fix has been published for CVE-2026-45116 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45116 being exploited?

There is no known exploitation of CVE-2026-45116 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45116 and fix it if it is affected.

What it is: CVE-2026-45116 is a high-severity cross-site scripting vulnerability in mybb, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45116 in the wild and no public exploit code.

Affected product: mybb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45116/ (Markdown: https://insights.sbomify.com/CVE-2026-45116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45116
- OSV: https://osv.dev/vulnerability/CVE-2026-45116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45116/
Summaries are generated and may contain mistakes; the official description above is the record.
